Completed
The scheduled maintenance has been completed.
Posted Aug 13, 2025 - 04:00 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 13, 2025 - 02:00 EDT
Scheduled
On Wednesday, 8/13/25, beginning at 2 AM EST, we will perform regularly scheduled software code updates on the ServiceChannel system. We expect the entire process to last less than 1 hour, but it may take up to 2 hours. We expect the system to be available during this time.
Posted Aug 08, 2025 - 11:59 EDT
This scheduled maintenance affected: Service Automation (Login, Dashboard, Work Order Manager, Proposal Manager, Invoice Manager, Asset Manager, Compliance Manager, Supply Manager, Weather, Project Tracker, Inventory Manager, Locations List, Maps), API (Authentication, API Response, SendXML, Universal Connector, Budget Insights), Mobile Applications (SC Mobile, SC Provider), Provider Automation (Fixxbook, Login, Work Order Manager, Proposal Manager, Invoice Manager, IVR), Analytics (Analytics Dashboard, Analytics Download), and WorkForce.