Servicechannel.com Brand Website Infrastructure Changes
Incident Report for ServiceChannel
Postmortem

This was an informational report only. There is no associated incident postmortem.

Posted Jan 12, 2021 - 23:09 EST

Resolved
This infrastructure change has been completed.
Posted Jun 17, 2020 - 22:39 EDT
Monitoring
From 11:30am to 1:00pm PDT, ServiceChannel is making infrastructural changes to the brand website at servicechannel.com. These changes will have no impact on the ServiceChannel application.

While every effort is being undertaken to limit the amount of downtime on the brand site, there may be some brief bumps along the way. We thank you for your patience.

To log into the ServiceChannel application, please go to https://login.servicechannel.com.

Thanks again for your patience and understanding while we make these changes!
Posted Jun 17, 2020 - 11:25 EDT