Inbound Email Delays
Incident Report for ServiceChannel
Resolved
After completing our monitoring and confirming that email is processing as expected, we consider this incident to be resolved. Thank you for your patience.
Posted May 30, 2020 - 16:50 EDT
Monitoring
The third-party service provider has completed their maintenance. We are monitoring to ensure that inbound emails are processing normally.
Posted May 30, 2020 - 16:28 EDT
Identified
Due to ongoing maintenance with a third-party service provider, inbound email processing is delayed. We will provide updates as we receive them.
Posted May 30, 2020 - 15:50 EDT
This incident affected: Third Party Components (Rackspace - Inbound Email).