Degraded Performance with Universal Connector

Incident Report for ServiceChannel

Resolved

This incident has been resolved. All old messages have been processed.
Posted Apr 07, 2026 - 12:00 EDT

Monitoring

A Fix has been implemented and we are monitoring the results.
New connector events are now processing and may appear out of sequence as old and new messages are now being processed in parallel.
Posted Apr 04, 2026 - 11:08 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 04, 2026 - 01:28 EDT

Investigating

We are currently investigating an issue which is impacting Universal Connector.
Posted Apr 03, 2026 - 20:13 EDT
This incident affected: API (Universal Connector).