Google's GSuite down
Incident Report for ServiceChannel
Postmortem

Attached is the link to Google GSuite service/incident details for June 2nd, 2019

https://www.google.com/appsstatus#hl=en&v=issue&ts=1559620799000&sid=1&iid=74a7efa47b9de665d02699bbe9dd11fc

Posted Oct 09, 2019 - 14:30 EDT

Resolved
This is an advisory message that Google is currently experiencing an outage across its G-Suite. ServiceChannel is functioning normally, but you may not receive Email Dispatches if using Gmail as your email tool. Please log in and monitor ServiceChannel for new Work Orders or items that may need attention. You can follow Google's status page here: https://www.google.com/appsstatus#hl=en&v=status
Posted Jun 02, 2019 - 18:14 EDT