Call Center Unable to Receive Calls
Incident Report for ServiceChannel
Resolved
Thanks for your patience. We consider this issue to be resolved.
Posted Apr 17, 2021 - 20:40 EDT
Monitoring
Our telecommunications provider has implemented a fix and inbound calls to our call center are flowing properly again. We will continue to monitor for the next 30 minutes.
Posted Apr 17, 2021 - 20:13 EDT
Investigating
Our call center staff are currently not able to receive inbound telephone calls. We are working with our telecommunications partner to restore service and will provide an ETA as soon as it becomes available.

Thank you for your patience!
Posted Apr 17, 2021 - 19:41 EDT
This incident affected: Service Center (Phone - Inbound).