Completed
The scheduled maintenance has been completed.
Posted Mar 08, 2025 - 06:00 EST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 08, 2025 - 02:00 EST
Scheduled
Please be advised that on Saturday, March 8th, starting at 2 AM EST (1 AM CST, 11 PM PST on March 7th, 7 AM GMT, and 8 AM CET), we will be performing scheduled maintenance on the ServiceChannel system. During this time, you will be redirected to a holding page, and the ServiceChannel platform, including the mobile application, will be unavailable.
We expect the maintenance to be completed within 4 hours, with service restored by 6 AM EST (5 AM CST, 3 AM PST, 11 AM GMT, and 12 PM CET).
Thank you for your understanding and patience.
Posted Feb 24, 2025 - 11:04 EST
This scheduled maintenance affected: Service Automation (Login, Dashboard, Work Order Manager, Proposal Manager, Invoice Manager, Asset Manager, Compliance Manager, Supply Manager, Weather, Project Tracker, Inventory Manager, Locations List), API (Authentication, API Response, SFTP, SendXML, Universal Connector, Budget Insights), Mobile Applications (SC Mobile), Analytics (Data Direct, Analytics Dashboard, Analytics Download), Provider Automation (Fixxbook, Login, Work Order Manager, Proposal Manager, Invoice Manager, IVR), and WorkForce.