Third-party Mobile App issue (Google Maps)
Incident Report for ServiceChannel
Postmortem

This was an informational report about a third-party service. There is no associated incident postmortem.

Posted Jan 12, 2021 - 23:10 EST

Resolved
Google has advised they've fixed the problem with their Google Maps integration. If you continue to experience issues with your mobile app, please clear your app data and try again.

Steps to clear the Android app's data:
-Open your phone's Settings app.
-Tap Apps & notifications.
-Tap the app. If you don't see it, first tap See all apps or App info.
-Tap Storage & cache ">" Clear storage or Clear data ">" OK.
Important: Settings can vary by phone. For more info, contact your device manufacturer.

We consider this issue resolved.
Posted Apr 23, 2020 - 20:25 EDT
Monitoring
Some mobile app users may experience their app force-closing suddenly. This is happening on Google's end and they are aware of the problem. As such, as soon as Google corrects the issue the ServiceChannel app will function properly.
Posted Apr 23, 2020 - 18:05 EDT
This incident affected: Mobile Applications (SC Mobile).