System Performance Issues
Incident Report for ServiceChannel
Postmortem

System Performance Issues Incident Report

Date of Incident:                   11/13/2019

Time/Date Incident Started: 11/13/2019, 11:46 am EDT

Time/Date Stability Restored:   11/13/2019, 03:53 pm EDT

Time/Date Incident Resolved: 11/13/2019, 05:00 pm EDT

Users Impacted: some users

Frequency: intermittent

Impact: Minor

 

Incident description:

Production database master encountered higher than usual workloads which led to intermittent blocks and system slowness, particularly around invoicing activities.

Root Cause Analysis:

Intermittent data sync process caused unusual database reads which led to suboptimal IO responses. This problem affected only the production database master (read replicas were unaffected).

Actions Taken:

  1. Offensive query was identified
  2. Optimization was implemented by recompiling and updating statistics
  3. Monitored and confirmed that master db requests cleared the backlog and executing within normal durations

Mitigation Measures:  

  1. Perform more aggressive optimizations on a more frequent schedule
  2. Assign engineering teams to review the traffic pattern responsible for the incident and optimize resource consumption
Posted Jan 12, 2021 - 22:25 EST

Resolved
Our team has restored stability to the affected subsystem, and the system is performing as expected. We consider this incident to be resolved, and thank you for your patience.
Posted Nov 13, 2019 - 15:12 EST
Investigating
We are currently investigating an intermittent issue that may cause long load times for certain components. We will provide an ETA shortly.
Posted Nov 13, 2019 - 13:52 EST
This incident affected: Provider Automation (Login, Work Order Manager, Proposal Manager, Invoice Manager) and Service Automation (Work Order Manager, Proposal Manager, Invoice Manager, Asset Manager).