System Outage Phone inbound / Five9

Incident Report for ServiceChannel

Resolved

This incident has been resolved.
Posted Aug 05, 2025 - 16:36 EDT

Identified

We are currently working with our Carrier to resolve inbound call issues at our Service Center.
Posted Aug 05, 2025 - 16:11 EDT

Update

We are continuing to investigate this issue.
Posted Aug 05, 2025 - 16:10 EDT

Investigating

The ServiceChannel SRE team is currently investigating an issue affecting the ServiceChannel platform. We will provide an ETA shortly. Thank you for your patience.
Posted Aug 05, 2025 - 16:09 EDT
This incident affected: Service Center (Phone - Inbound).