ServiceChannel - Fixxbook Provider Profile Viewing
Incident Report for ServiceChannel
Postmortem

Compliance Manager Outage Incident Report 

  

Date of Incident:                   5/8/2024 

  

Time/Date Incident Started: 5/8/2024, 12:01 pm EDT 

Time/Date Stability Restored:   5/8/2024, 1:30 pm EDT 

Time/Date Incident Resolved: 5/8/2024, 1:41 pm EDT 

 

Users Impacted: Users utilizing the Fixxbook Compliance Manager 

Frequency: Duration of the incident event 

Impact: Major 

Incident description: 

At 12:00 EDT on May 8th, the Site Reliability Engineering (SRE) team responded to increased error rates through alerts, followed by user reports of malfunctions within the ServiceChannel Fixxbook service. This issue affected Fixxbook users, particularly those using features of the Compliance Manager, leading to a less than ideal user experience.

   

Root Cause Analysis: 

After an in-depth analysis, the Site Reliability Engineering (SRE) team pinpointed the errors and discovered that an incorrectly set DNS record was disrupting the functionality of the Fixxbook application. The issue was promptly resolved, and the application's performance was reinstated to full capacity. The SRE team maintained vigilant oversight to confirm the application's sustained stability. 

 

Actions Taken: 

  1. Manually tested our services to replicate the issue. 
  2. Investigated system-generated alerts and identified affected platform functionality.   
  3. Updated DNS entry to restore functionality. 

Mitigation Measures:    

  1. Introduced enhanced alerting mechanisms designed to rapidly and more precisely detect issues within the Fixxbook application components.
Posted May 17, 2024 - 16:22 EDT

Resolved
This incident has been resolved. All services are working as expected.
Posted May 07, 2024 - 14:03 EDT
Monitoring
A fix has been implemented and you should be able to view provider profiles on Fixxbook now. We will continue to monitor to ensure stability going forward.
Posted May 07, 2024 - 13:38 EDT
Investigating
We are actively investigating an issue with errors occurring while viewing provider profiles on Fixxbook. An update will be provided shortly. Thank you for your patience.
Posted May 07, 2024 - 12:39 EDT
This incident affected: Service Automation (Compliance Manager).