SC Provider App
Incident Report for ServiceChannel
Postmortem

Date of Incident: 07/10/2019

Time/Date Incident Started: 07/10/2019, 10:07 AM EST

Time/Date Stability Restored: 07/10/2019, 12:45 PM EST

Time/Date Incident Resolved: 07/10/2019, 12:45 PM EST

Users Impacted: Legacy Internal Provider Technicians (Not field technicians)

Frequency: Intermittent

Impact: Minor

Incident description:

Certain internal provider technician users could not complete check in/out.

Root Cause Analysis:

We identified an issue with legacy accounts setup as internal accounts without an email address configured. A bug was inadvertently introduced during the latest web release causing those users to experience a disruption to check in/out functionality.

Actions Taken:

  1. After identifying the underlying issue, we added placeholder email addresses to accounts to satisfy the required email field causing the issue.

Mitigation Measures:

  1. We have added additional testing steps to address these legacy use cases.
  2. In a future software release, we will upgrade these accounts from the legacy account type.
Posted Oct 09, 2019 - 14:34 EDT

Resolved
We're currently investigating an issue where some users on the SC Provider App are unable to check in to a Work Order. This is being addressed with the highest priority and updates will be provided as soon as possible.

...

This issue has been resolved. The SC Provider App is now working as expected and users should be able to check in without issue. Please reach out to our Support team if you have any questions.
Posted Jul 10, 2019 - 10:07 EDT