System Interruption Announcement

Incident Report for ServiceChannel

Resolved

This incident has been resolved.
Posted Jul 10, 2025 - 15:09 EDT

Monitoring

We have released a fix that resolves the reported issues with provider user updates. The system is now functioning as expected, and we will continue to monitor performance closely.
Thank you for your patience.
Posted Jul 10, 2025 - 12:15 EDT

Update

We are continuing to investigate this issue.
Posted Jul 10, 2025 - 11:14 EDT

Investigating

We are currently experiencing intermittent issues with Provider users adding Notes to work orders. Our Engineering Team is releasing a fix to resolve the issue and restore full functionality.
We appreciate your patience and will provide updates as more information becomes available.
Posted Jul 10, 2025 - 11:13 EDT
This incident affected: Service Automation (Work Order Manager, Invoice Manager).