Issues with Inventory Admin

Incident Report for ServiceChannel

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 02, 2026 - 20:41 EDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 02, 2026 - 12:01 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 02, 2026 - 12:01 EDT

Investigating

Inventory Admin is currently experiencing some issues. Users can continue to access and use inventory through the mobile app and other non-admin inventory functions.
Posted Sep 02, 2026 - 12:00 EDT
This incident affects: Service Automation (Inventory Manager).