System Performance Degradation
Incident Report for ServiceChannel
Resolved
The ServiceChannel engineering team has implemented a fix which has allowed us to re-enable the new Work Orders Report page for Providers. Out of an abundance of caution, the fix was phased in for providers on a rolling basis over several hours. We consider this issue to be resolved.
Posted 7 months ago. Mar 22, 2019 - 17:25 EDT
Identified
The system is behaving normally for Subscribers.

For Providers, we have temporarily disabled the new Work Orders Report page. To retrieve work orders, please follow these steps:
1. Click on 'Work Orders' from top Menu
2. Within the page, click on 'Back to Previous Version' (found on the top right)

We are working toward a permanent resolution to this issue and will continue to update with progress.
Posted 7 months ago. Mar 21, 2019 - 14:21 EDT
Update
We are still investigating the system performance issues. We will report any updates as soon as they become available. Our engineering teams are treating this with the highest priority.
Posted 7 months ago. Mar 21, 2019 - 12:02 EDT
Investigating
We are currently observing degraded system performance. Our engineering teams are actively working on this and we will provide updates as soon as possible.
Posted 7 months ago. Mar 21, 2019 - 09:57 EDT
This incident affected: Call Center, Service Automation, Store Dashboard, and Mobile Applications.