Analytics Access
Incident Report for ServiceChannel
Postmortem

Date of Incident: 02/18/2019

Time/Date Incident Started: 02/18/2019, 7:45am EST

Time/Date Stability Restored: 02/18/2019, 11:30 EST

Time/Date Incident Resolved: 02/18/2019, 11:30 EST

Users Impacted: Active users

Frequency: Once

Impact: Partial

Incident description:

Analytics (Proview) access via ServiceChannel was temporarily blocked, with users receiving a 405 error, due to some changes rolled out to our vendors API that facilitate single sign on between ServiceChannel and their platform.

Root Cause Analysis:

A support ticket raised with our vendor revealed that they had deprecated the SSO GET method that is used by ServiceChannel to authenticate our users with their platform for seamless access to analytics within our environment. This was deprecated in favor of an HTTP POST method.

Actions Taken:

A support ticket was raised with our vendor which allowed us to identify the root cause.

Our vendor temporarily reverted their changes to deprecate the HTTP Get method, thus re-enabling single sign on.

ServiceChannel developers have finalized and are testing changes to utilize the HTTP post method going forward.

Mitigation Measures:

ServiceChannel developers have finalized and are testing changes to utilize the HTTP post method going forward.

We are working with our vendor to review upcoming planned functionality on their platform to avoid any future occurrences.

Posted 6 months ago. Feb 27, 2019 - 11:13 EST

Resolved
Access to the Analytics module has been restored. This issue is now resolved.
Posted 6 months ago. Feb 18, 2019 - 11:47 EST
Investigating
We are currently experiencing an issue with our Analytics platform. We are working with the provider on getting this fixed with the highest priority. Updates will be sent as soon as possible.
Posted 6 months ago. Feb 18, 2019 - 09:59 EST
This incident affected: Analytics.