Proposal Assignment Email Notifications
Incident Report for ServiceChannel
Postmortem

.Proposal Email Bug Incident Report

Date of Incident: 04/17/2019

Time/Date Incident Started: 04/17/2019, 3:05 pm EST

Time/Date Stability Restored: 04/25/2019, 2:40 pm EST

Time/Date Incident Resolved: 04/25/2019, 2:40 pm EST

Users Impacted: Active users

Frequency: Once

Impact: Partial

Incident description:

Email alerts not delivered when reassigning a proposal to a different user.

Root Cause Analysis:

Per our investigation, we identified there was an invalid configuration responsible for processing proposals. This required a change to be released to production to resolve the issue.

Actions Taken:

Identified the missing configuration values

Tested changes on lower environments

Released to production

Mitigation Measures:

Added functionality in automated tests to check for email functionality around proposal reassignment.

Posted 2 months ago. Jun 12, 2019 - 12:58 EDT

Resolved
We have corrected the issue with Proposal emails not being sent when assigned. This incident is resolved.
Posted 4 months ago. Apr 25, 2019 - 14:40 EDT
Investigating
We are investigating reports of email alerts not being delivered when reassigning a proposal to a user.
Posted 4 months ago. Apr 17, 2019 - 15:05 EDT
This incident affected: Email Processing.