Fixxbook Log-in Link Redirect Issue
Incident Report for ServiceChannel
Postmortem

Date of Incident: 02/28/2019

Time/Date Incident Started: 02/28/2019, 6:30 am EST

Time/Date Stability Restored: 02/28/2019, 10:25 am EST

Time/Date Incident Resolved: 02/28/2019, 10:25 am EST

Users Impacted: Fixxbook users logging in via URL: fixxbook.com

Frequency: Intermittent

Impact: Partial

Incident description:

Following the issue on 2/20, we have rolled back changes that day related to URL redirect until further notice. Unfortunately, the site had information stored in a cookie related to redirects and as this information expired, some users experienced an issue accessing Fixxbook today.

Root Cause Analysis:

Issue affected login for Fixxbook.com and applied to users that had redirect information expiring today or have not visited the site in a long time.

This incident was related to the original issue reported on 2/20 and was not introduced by further code changes.

Actions Taken:

The team today moved forward with moving fixxbook to the new domain and making the necessary changes in all places to finalize this move.

As a work-around, impacted users were directed to use the alternate URL https://fixxbook.servicechannel.com/Home/Login

In addition, cached items were flushed so no further caching problems would occur.

The new changes were deployed at 10:25 am EST

Fixxbook login, SSO and all related links were tested successfully.

Mitigation Measures:

We have finalized this one time change and resolved for all users.

Our recent actions from 2/20 allowed us to troubleshoot and fix this issue in a shorter time frame and we continue to improve our processes.

Posted 4 months ago. Feb 28, 2019 - 14:28 EST

Resolved
We updated the login endpoint in fixxbook.com to point to the new resource location. Login is working as intended.
Posted 4 months ago. Feb 28, 2019 - 11:05 EST
Investigating
As part of our move towards our new and improved Compliance Manager, we have changed our direct login link for Fixxbook. For users who are not using the SSO from ServiceChannel to Fixxbook, they may have encountered an error upon logging in this morning

As a work-around, you may log in through the following link: https://fixxbook.servicechannel.com/Home/Login
Posted 4 months ago. Feb 28, 2019 - 10:10 EST
This incident affected: Fixxbook.