System Performance Degradation
Incident Report for ServiceChannel
Resolved
All services are confirmed running as expected. We consider this incident to be resolved.
Posted 2 months ago. Apr 04, 2019 - 14:14 EDT
Investigating
We are currently observing degraded system performance. Our engineering teams are actively working on this and we will provide updates as soon as possible.
Posted 2 months ago. Apr 04, 2019 - 12:40 EDT
This incident affected: Call Center, Service Automation, and Store Dashboard.